squatter -F increases the index size

Dilyan Palauzov Dilyan.Palauzov at aegee.org
Fri May 31 14:33:43 EDT 2019


I gave squatter -F a try.

Before I run it for a user tier T1 was not compacted and allocated 3,4  
MB (mega), T2 was compacted and contained 3.7GB (giga).  After  
removing the records of the deteled messages, say running squatter -F  
T2 was 5.7GB and squatter printed “filtering” instead of “compacting”.  
  Then I run again “squatter -t T1,T2 -z T2” without -F, without -X  
and squatter reindexed all messages, to create a 3.0 GB index.

I expected, that using -F the resulting database will be compacted and  
on the second call there will be no reindexing.

When does squatter decide on its own to reindex?

What do G records in conversations.db contain?

My reading is that the way to create a Xapian index of an indexed  
mailbox, is that first squatter has to be run in INDEX mode and then  
in COMPACT mode.  In particular it is not possible to create in one  
step a compacted database.

Does squatter -R -S sleep after each mailbox or after each message indexed?

When compacting, squatter deals just with messages and on search or  
reindex the conversations.db is used to map the messages to mailboxes.  
  How does squatter -S sleep after each mailbox during compacting, if  
it knows nothing about mailboxes?

What does mean a tier name in a xapianactive file without a number?


What does the file sync/squatter?

squatter can print “Xapian: truncating text from message mailbox  
user.... uid 7309”.  When are messages truncated for the purposes of  

Do I understand correctly, that for a Xapianactive file with "A B C D  
E", to remove C one has to call "squatter -t C,D -z D".  But A cannot  
be removed, if it the defaultsearchtier.  Is the defaultsearchtier  
always included in the xapianactive file, if the tier is missing,  
whenever the file is modified (and the only way to modify it is to  
call squatter in COMPACT mode)?


More information about the Cyrus-devel mailing list