GSSAPI Error: An invalid name was supplied (Not enough space)

Dan White dwhite at
Thu Nov 13 09:23:28 EST 2008

Ben Lentz wrote:
>> You can enter the host/IP into /etc/hosts, or if your dns resolves 
>> correctly, then you shouldn't need to. I was 
>> getting a Local Error as well due to a bad entry in my /etc/hosts.
>> - Dan
> Everything's working find in DNS. I can get a ticket without any 
> problems using kinit (from mit or heimdal), but the ldapsearch portion 
> still gives the same error. I tried doing this using binaries on 
> CentOS 5, and it worked fine. For some reason when I compile it on 
> AIX, it doesn't work. I tried running everything as root, and I tried 
> modifying /etc/netsvc.conf (e.g. /etc/nsswitch.conf), but it didn't 
> help. I also searched the source code from krb5, cyrus-sasl, and 
> openldap, and couldn't find the "Not enough space" string anywhere. 
> The "An invalid name was supplied" was found in the krb5 gssapi code.
> Does anyone have any experience with this? I've googled it to death, 
> and the only solid result I'm getting are references to this thread on 
> the mailing list archives... not a good sign. :-(


Have you wiresharked it? (filter: kerberos)

- Dan


-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Cyrus-sasl mailing list