MSVC cannot build stdint.h not found

Jan Harkes jaharkes at
Mon Dec 6 17:07:06 EST 2010

On 12/06/2010 02:48 PM, Stefan König wrote:
> i've got a problem building open slide with MSVC 2008 Professional, I
> created my solution file with cmake and tried to build it.

Interesting, I didn't know MSVC was not at all C99 compliant. It looks
like there are several projects that try to provide usable stdint.h and
inttypes.h headers. These are both BSD licensed, so I guess either of
these can probably be integrated into the openslide build using an
autoconf test or somehow into the cmake.

> But I get several errors "stdint.h" not found, i tried to apply a stdint.h
> file from mingw to path. Then the missing stdint disappeared, but now I get
> some other errors, mostly in sha*.h.

I don't know what your errors are, but I don't think it is trivial to
just pull an isolated header out of the mingw build environment, it
probably depends on various other mingw headers. Then again there may be
other C99 coding issues in the sha* header and source files that fail
with MSVC compilers, a fix for one such incompatibility in a prototype
was just merged into the main github tree earlier today.


More information about the openslide-users mailing list