Moving from cIMAP-2.3.16 to 3.0.5

James B. Byrne byrnejb at
Sat May 12 17:03:51 EDT 2018

I have used rsync to move our entire maill store from the old server
to the new.  I now I wish to move the contents of mailboxes.db from
the old to the new.  I have tried:

sudo -u cyrus /usr/lib/cyrus-imapd/ctl_mboxlist -d -f

on the old followed by a transfer of /var/spool/imap/mailboxes.db.txt
to the new followed by:

sudo -u cyrus /usr/local/cyrus/sbin/ctl_mboxlist -u  -f
/var/spool/imap/mailboxes.db.txt on the new

 and all I get is a blank line and no indication in ps that the task
is consuming any cpu.

If I press <cr> I see this:

line 1: no partition found

line 2: no partition found

line 3: no partition found

. . .

There is only one partition on both systems and it is
'/var/spool/imap' on both.

I have also tried the method suggested on the 3.0.6 documentation
respecting upgrading and use rsync to move over mailboxes.db.  In each
case I cannot get reconstruct to run and upgrade or rebuild the mail
store on the new service.

# sudo -u cyrus /usr/local/cyrus/sbin/reconstruct -r -f -V *

I get an immediate empty return.

I know that there exist physical mailboxes on the server that cyradm
does not report.  I know that these mailboxes exist on the old server
and therefore I infer are present in mailboxess.db.

How do I get the contents of the old mailboxes.db file into the new so
that reconstruct will run?

***          e-Mail is NOT a SECURE channel          ***
        Do NOT transmit sensitive data via e-Mail
 Do NOT open attachments nor follow links sent by e-Mail

James B. Byrne                mailto:ByrneJB at
Harte & Lyne Limited
9 Brockley Drive              vox: +1 905 561 1241
Hamilton, Ontario             fax: +1 905 561 0757
Canada  L8E 3C3

More information about the Info-cyrus mailing list