Upgraded cyrus 3.0.1: lmtpd segfaults

Nicola Nye nicolan at fastmail.com
Tue May 16 19:32:31 EDT 2017

Hi Sandra,

The issue you linked to was due to an issue with some sieve scripts. The
administrator tried compiling the system scripts by hand using sievec to
work out which ones were no good. They were then removed/fixed.
This documentation tells you how to enable core dumps:

Once your lmtp segfaults, it should dump core.

Then you can fire up gdb:

gdb /usr/local/cyrus/lmtpd /tmo/core.XXX  (use proper locations) 

At the (gdb) prompt run the backtrace command (bt).

This should give you a stack trace. Please post it here and we'll see if
that tells us what's going wrong.
Good luck,


On Wed, May 17, 2017, at 04:27 AM, Sandra R. S. Pisciotto wrote:
> Hello everybody,
>     I am trying to upgrade my cyrus-2.4.17 to cyrus-3.0.1 but I have
> found some problems with lmtp segfaults as
> described some time ago in this info-cyrus thread
> https://lists.andrew.cmu.edu/pipermail/info-cyrus/2015-November/038585.html> 
>     I want to know it this problem has been solved, because I can use> autocreate in my cyrus-murder configuration.
>     Is there any solution?
> Thanks a lot.
> Sandra
> ----
> Cyrus Home Page: http://www.cyrusimap.org/
> List Archives/Info: http://lists.andrew.cmu.edu/pipermail/info-cyrus/> To Unsubscribe:
> https://lists.andrew.cmu.edu/mailman/listinfo/info-cyrus

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.andrew.cmu.edu/pipermail/info-cyrus/attachments/20170517/9bc21ae7/attachment.html>

More information about the Info-cyrus mailing list