Cyrus domain resolution

Vilius Šumskas vilius at
Wed Mar 23 08:25:51 EDT 2011


I was running Cyrus 2.3.7 on RHEL 5 just fine for the past several years. Recently I upgraded from physical machine to virtual and from RHEL 5 to RHEL 6. Cyrus IMAPD was upgraded to the 2.3.16 which comes with RedHat. What needs to be noted that IP of the server have changed. I'm not sure if I'm missing something but domain resolution doesn't work as it worked before. %r always resolves to 'hostname.domain.tld'.

This is my imapd.conf:

virtdomains: on
configdirectory: /var/lib/imap
partition-default: /var/spool/imap
admins: cyrus
sievedir: /var/lib/imap/sieve
sendmail: /usr/sbin/sendmail
hashimapspool: false
sasl_log_level: 9
sasl_pwcheck_method: auxprop
sasl_auxprop_plugin: sql
sasl_password_format: crypt
sasl_sql_user: aaaaaa
sasl_sql_passwd: aaaaaaaa
sasl_sql_hostnames: localhost
sasl_sql_database: mail
sasl_sql_select: select password from accountuser where username = '%u' and domain_name = '%r'
sasl_mech_list: PLAIN LOGIN
allowplaintext: yes
tls_cert_file: /etc/pki/cyrus-imapd/cyrus-imapd.pem
tls_key_file: /etc/pki/cyrus-imapd/cyrus-imapd.pem
tls_ca_file: /etc/pki/tls/certs/ca-bundle.crt
allowanonymouslogin: 0
autocreatequota: 512000
reject8bit: no
quotawarn: 90
timeout: 30
poptimeout: 10
lmtp_downcase_rcpt: yes

The things I tried:

1) Disable domain resolution according to IP (as per virtualdomains.html) with virtdomains: userid. %r still resolves to '' even if in Outlook the user is as 'user at'.
2) Set virtdomains: on and configuring reverse record for an IP to ''. %r still resolves to ''.
3) Set virtdomains: on and configuring reverse record for an IP to ''. Strangely now %r resolves to 'com'. (??)

The only thing that helps is setting  servername: in the config. But this is not what I want. My servername is ''.

Any ideas? A bug?

  Best Regards,

  Vilius Šumskas
  LNK TV IT manager
  mob.: +370 614 75713

More information about the Info-cyrus mailing list