After upgrade to 2.4.6 I'm not able to expunge messages

Bron Gondwana brong at
Tue Mar 8 06:28:17 EST 2011

On Tue, 8 Mar 2011 11:41:07 +0100
Martin Schweizer <schweizer.martin at> wrote:

> Hello
> I found the problem. It was not the file system or the expunged
> messages. It was the quotas which are broken. After I startet quote -f
> all was correct. Sorry for boring.
> One thing is I do not understand: If I delete a message (in the imap
> client and close the client) which is older then expunged (as defined
> in imapd.conf) and I run then cyr_expire -v -X 1 -E 1  I expect
> cyr_expire showed me this deleted messages. But I can't see this
> messages. Why?

cyr_expire will remove (unlink) messages that were expunged more than N days ago.
Separately, it will also expunge messages based on an annotation (if present)
for auto-expunging.

The unlink will only happen -E days AFTER the expunge.  Not after the messages was created.  Even if cyr_expire did the expunge, it still doesn't unlink it
straight away.  The theory is that this gives the user time to notice the message has gone and request a restore!


More information about the Info-cyrus mailing list