Deliver to mailbox problem with v2.4.7

John cyrus at
Sat Apr 9 17:33:46 EDT 2011

On 07/04/11 22:43, Dan White wrote:
> On 07/04/11 23:23 +0100, John wrote:
>> On 07/04/11 22:06, Dan White wrote:
>>> 'deliver' should deliver to the user's INBOX if it believes there's a
>>> permissions problem, or if it believes the mailbox doesn't exist. Does
>>> syslog give you any hints?
>>> What does your configuration look like? How are 'unixhierarchysep' and
>>> 'altnamespace' configured?
>>> To trouble shoot, try setting an 'anyone p' acl on your subfolder, 
>>> or try
>>> one of:
>>> /usr/cyrus/bin/deliver -a john -m folder.subfolder john < message
>>> /usr/cyrus/bin/deliver -a john -m INBOX/folder/subfolder john < message
>> Nothing in syslog that really helped.
>> I have both "unixhierarchysep" and "altnamespace". From my conf:
>> configdirectory: /srv/mail/cyrus
>> partition-default: /srv/mail/cyrus/mail
>> admins: cyrus
>> sasl_pwcheck_method: saslauthd
>> altnamespace: yes
>> unixhierarchysep: yes
>> Nothing in that respect has changed. I've always had "altnamespace" to
>> give me folders at the same level as INBOX and I've always had
>> "unixhierarchysep" to give me folder separator of "/" rather than "." (I
>> actually use the "." in some folder names).
>> My config worked fine for me for a very long time until I had to upgrade
>> earlier this week. I think my ACLs are fine:
>> localhost.localdomain> lm user/john
>> user/john (\HasChildren)
>> localhost.localdomain> lm user/john/
>> user/john/ (\HasChildren)
>> localhost.localdomain> lam user/john/
>> john lrswipcda
>> localhost.localdomain> lam user/john
>> john lrswipcda
>> localhost.localdomain>
>> So I am stumped :)
>> Thanks for helping, much appreciated.
> Assuming this is a bug, can you set an 'anyone p' acl on the mailbox
> (parent and subfolder) to see if it delivers?
> Do you have any unusual characters in your folder names (like a dot?). 
> Can
> you attempt to deliver to a 'top level' folder underneath user/john/?
> does the parent and subfolder show up in the output of 'ctl_mboxlist -d'?
> Does your folder list look sane if you connect via an IMAP client?
Sorry for delay in responding, I have been away.

Setting "anyone p" made no difference:

localhost.localdomain> sam user/john anyone p
localhost.localdomain> lam user/john
john lrswipcda
anyone p

localhost.localdomain> sam user/john/ anyone p
localhost.localdomain> lam user/john/
john lrswipcda
anyone p

I've tried adding "anyone p" to user/john, user/john/ and 
user/john/ None made any difference - delivery is 
still to INBOX.

I do have unusual characters - specifically I have dots in them (which 
is why I use "unixhierarchysep").
My folders are for example user/john/

# /usr/cyrus/bin/ctl_mboxlist -d | grep subfolder
user.john.folder^name.subfolder 0 default john  lrswipcda       anyone  p
# /usr/cyrus/bin/ctl_mboxlist -d | grep "" | head -1
user.john.folder^name   0 default john  lrswipcda       anyone  p

The folder list is sane in imap client. Everything is working fine 
except delivery into folders. All mail already delivered prior to 
upgrade is in folders and perfectly readable as I would expect.

More information about the Info-cyrus mailing list