messages in mailbox aren't visible

Patrick Goetz pgoetz at
Tue Oct 12 08:24:25 EDT 2010

Hi -

I'm stumped by the following problem.  recently I transferred a bunch of 
users to a new 2.3.16 cyrus server.  One user in particular has hundreds 
of mailboxes nested several levels deep.  Most folders transferred 
correctly.  One of these subfolders, however,

   user.bubba.AMG."Correspondence ABC".Board

contains further subfolders and messages.  The subfolders show up, but 
not the messages in the folder.  Similar folders in other parts of the 
folder tree don't have this problem.

I tried unsubscribing and re-subscribing to the folder, this didn't help.

I've tried using cyradm to (re)create the mailbox:
   cm user.bubba.AMG."Correspondence ABC".Board
and got "Mailbox already exists".

I've tried using reconstruct:
  cyrreconstruct -f user.bubba.AMG."Correspondence ABC".Board
and this didn't help, either.  After doing a little googling I suspect 
that the IMAP \Noselect flag is set.

Is there some straightforward way to reset this flag on this mailbox or 
am I stuck with connecting to the server:

   openssl s_client -starttls imap -connect localhost:143
   x login user pass
   x etc.

and muddling through running IMAP commands by hand?  If so, what is the 
IMAP command for unsetting \Noselect?

More information about the Info-cyrus mailing list