Tcpwrapper does not work?

Paul van der Vlis paul at
Fri Oct 8 10:33:44 EDT 2010

Dave McMurtrie schreef:
> On 10/08/2010 07:24 AM, Paul van der Vlis wrote:
>> Dave McMurtrie schreef:
>>> On 10/08/2010 06:09 AM, Paul van der Vlis wrote:
>>>> Hello,
>>>> When I put in my /etc/hosts.deny this: imapd:
>>>> And /etc/hosts.allow is empty.
>>>> Then I still get my mail over IMAP from this IP with Cyrus.
>>>> I use Cyrus 2.2.13 from Debian stable, so far I know this is compiled
>>>> with tcpwrapper support.
>>>> Does somebody understand this?
>>> Hi Paul,
>>> The service you specify for tcpwrappers in /etc/hosts.deny must be the
>>> same as the service name you put in /etc/cyrus.conf.  Most likely you
>>> want to use "imap" as the service and not "imapd"
>> I've tried it, and you are right (and so is Hajimu).
>> Strange, in the manual of tcp-wrappers they say you need to use the
>> processname...
> It's difficult to document this correctly from the tcp-wrappers side 
> because libwrap doesn't determine the service name itself.  Rather, 
> applications that link against libwrap have to tell libwrap the service 
> name they're using.
> Wrapping a service with tcpd in inetd.conf was more intuitive because 
> the service name was specified on the same line in inetd.conf.

I am using now this because I found-out that "imap" did not help against
pop3 access.

imap pop3:

I have "idled" enabled. Not sure if I need to add that.

I don't have imaps and pop3s (I only use TLS), but when I would have it,
I think I have to add them too?  And maybe "sieve" ?

With regards,
Paul van der Vlis.


More information about the Info-cyrus mailing list