IMAP not seeing old mail present on filesystem

Bron Gondwana brong at
Mon Oct 4 09:47:09 EDT 2010

A script to find each file and IMAP append it? Just thinking outside the box here!

"Chris Pepper" <pepper at> wrote:

>On 10/4/10 9:17 AM, Simon Matter wrote:
>>> Simon,
>>> 	I did recover /var/lib/imap (although a bit later, FWIW) and
>> I think "a bit later" is your problem. But I think reconstruct should fix
>> this.
>> BTW, did you check the subscription status of mailboxes? Maybe the folders
>> are there but not subscribed, and that's why some users can't see them?
>	No, users see the folders, just not old messages. For most (all?) 
>INBOXes but my own, new messages started arriving as 1. and continued 
>from there. Users can see the new mail, but not the old. This makes me 
>think it's not an internal permissions problem, because they see the 
>mailboxes and (some) mail in them. All file permissions I checked appear 
>	"reconstruct -rfx" doesn't help. Is there anything else to try?
>>> /etc/imapd.conf. I just now compared /etc/cyrus.conf and added squatter
>>> &  adjusted prefork numbers -- the rest all matched.
>>> 	Is there other configuration I should check? Both systems are 64-bit
>>> CentOS 5, so the db4 installations should be fully compatible.
>> If both the old and the new system are basically the same I don't think
>> there is anything missing.
>> Simon
>>> Thanks,
>>> Chris
>>> On 10/4/10 8:36 AM, Simon Matter wrote:
>>>>> All,
>>>>>        I have run a small mail service based on Cyrus IMAP for a few
>>>>> years. The (CentOS 5) server I've used for the past couple years failed
>>>>> last week. I brought up a new CentOS 5 system on a new Linux server,
>>>>> installed cyrus-imapd-2.3.7-7.el5_4.3, mounted the old /var disk
>>>>> (actually one of 2 mdadm submirrors), and copied /var/spool/imap over
>>>>> to
>>>>> the new /var FS. It's running CentOS' cyrus-imapd-2.3.7-7.el5_4.3 RPM.
>>>> Did you also recover /var/lib/imap from the old server and make sure the
>>>> configs are the same?
>>>> Simon
>>>>>        Unfortunately, for many users (all but me?), mail clients (at
>>>>> least
>>>>> Apple's and SquirrelMail) don't show any messages from before
>>>>> the migration in INBOX. When I grope around in /var/spool/imap/user, I
>>>>> see the old message (with high numbers) and the new messages (starting
>>>>> a
>>>>> new sequence from 1).
>>>>>        I know there are last-message counters in the cyrus.* files, so
>>>>> would resetting those have caused IMAP to start storing new messages
>>>>> from 1. and vanish the old ones? I don't know how those could have been
>>>>> cleared for at least 6 users simultaneously. Presumably it happened for
>>>>> all, and I just fixed it for myself somehow.
>>>>>        More importantly, I don't know how to make the old messages
>>>>> accessible to my users via IMAP (I can give them the files, but that's
>>>>> quite awkward). chk_cyrus agrees with IMAP clients about message counts
>>>>> (very low). I have tried reconstruct with various combinations of
>>>>> "-rfx", and "quota -f", but not found any way to make it show the old
>>>>> messages.
>>>>> Any suggestions?
>Cyrus Home Page:
>List Archives/Info:

Sent from my Android phone with K-9 Mail. Please excuse my brevity.

More information about the Info-cyrus mailing list