Bug? xfermailbox seems to be broken but using rename to xfer a mailbox works just fine.

Janne Peltonen janne.peltonen at helsinki.fi
Mon May 4 01:42:54 EDT 2009

On Thu, Apr 30, 2009 at 11:05:14AM -0400, Brian Awood wrote:
> > I get
> >
> > Apr 30 10:24:45 m2cn1t m2v1t/imap[3793]: could not dump mailbox in
> > m2v2t.mappi.helsinki.fi (unknown error) Apr 30 10:24:45 m2cn1t
> > m2v1t/imap[3793]: Could not move mailbox: user.atest001r,
> > dump_mailbox() failed
> >
> > in my murder frontend log, the command (in cyradm) never returns,
> It looks like error was logged from your frontend host m2v1t, so I 
> would guess that the xfer command was issued to it, which isn't 
> correct.  You have to connect to the backend where the mailbox is 
> stored and give the xfer command there.

Oh, of course. Thanks. :) (The fact that 'rename' worked on the frontend,
apparently because it got proxied to the correct backend, was confusing. :)

> But the fact that your frontend database gets corrupted like and that you
> didn't get a better error (like "mailbox not local"), definitely seems like a
> bug.  What is you mupdate_config set to on your frontend?  

Standard. I tried to run a unified murder for a while a couple of years before,
but run into so many bugs that I decided to use the standard config.

Janne Peltonen <janne.peltonen at helsinki.fi> PGP Key ID: 0x9CFAC88B
Please consider membership of the Hospitality Club (http://www.hospitalityclub.org)

More information about the Info-cyrus mailing list