Strange bug in cyrus (missing folders with reconstruct !)

Brian Awood bawood at
Thu Dec 17 21:48:06 EST 2009

On Thursday 17 December 2009 @ 18:38, Denis BUCHER wrote:
> Hello Brian,
> Correct ! It worked (I tried with a folder)
> > The "-rf" functionality is slightly different because it
> > needs a valid mailbox to start from.
> > If you have a lot of these cases, you might be able to automate this
> > by running "ctl_mboxlist -v" and cutting out the mailboxes that are
> > listed as being on the filesystem but not in the database.
> Do you mean something like /usr/sbin/ctl_mboxlist   -d -x  -p default ?
> I didn't find how to list folder present in system but not it
> database...
> Denis

No, at least in cyrus 2.3 just "/usr/sbin/ctl_mboxlist -v" will scan the 
entire filesystem and look for mailboxes that are not in the mailbox 
database or vis-versa.  
# /usr/sbin/ctl_mboxlist -v
'user.ddjdjdj.498' has a directory '/var/spool/imap/L/user/ddjdjdj/498' 
but no DB entry

depending on how many mailboxes you have, it may take quite a while to 
run.  But you should be able to take that output and use your favorite 
text processing utility to take the first field and pass it to 


More information about the Info-cyrus mailing list