Cyrus with a NFS storage. random DBERROR

Michael Menge michael.menge at
Wed May 2 11:19:22 EDT 2007


Cyrus has 2 problems with NFS.

1. Cyrus depends on filesystem locking. NFS-4 should have solved this problem
but i have not tested it.

2. BerkleyDB uses shared Memory which does not work accros multiple servers.

You can try to convert all your databases to skipplist and run with  
NFS-4 and proper filesystemlocking.

But as far as i know only skiplist and GFS is tested in a setup like yours.
Have a look at the threads on Cyrus and Cluster Filesystem and Cyrus HA.

Some time ago i wrote a summery of the infos in these threads, and  
wanted to add it to the Wiki, but had no sucsess so far.



Quoting ram <ram at>:

> I testing cyrus with a NFS storage by two *identical* cyrus + postfix
> servers
> Both /var/spool/imap and /var/imap are mounted by both servers ( the
> socket directory is moved out of the mount)
> Everything seems working fine but I find sometimes dupelim doesnt work.
> I tried to  debug , I get errrors like these in my maillog
> DBERROR: skiplist recovery /var/imap/deliver.db: ADD at E2C8 exists
> What could be the reason ?
> I am using cyrus-imapd 2.3.7 on centos 4.4  on both servers , with a
> NetAPP box for storage
> Thanks
> Ram
> ----
> Cyrus Home Page:
> Cyrus Wiki/FAQ:
> List Archives/Info:

M.Menge                                 Tel.: (49) 7071/29-70316
Universitaet Tuebingen                  Fax.: (49) 7071/29-5912
Zentrum fuer Datenverarbeitung          mail:  
michael.menge at
Waechterstrasse 76
72074 Tuebingen
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 5469 bytes
Desc: S/MIME krytographische Unterschrift
Url :

More information about the Info-cyrus mailing list