virtual domain mailbox cross contamination

Adam D emlists at
Sat Aug 11 12:48:56 EDT 2007

Jarod Watkins wrote:
> [snip]
>> Jarod,
>> I agree about trying to figure out if the mis-configured is related to
>> cyrus or postfix.  It has been a vicious circle trying to figure out
>> which one maybe configured wrong.  I have postfix configured to use
>> virtual alias domains and maps then deliver to cyrus with:
>> main.conf:
>> mailbox_transport = cyrus
>> master.conf
>> cyrus     unix  -       n       n       -       -       pipe
>>   flags=R user=cyrus argv=/usr/sbin/cyrdeliver -e -m ${extension} ${user}
>> I am guessing maybe when postfix delivers the mail to cyrus it is set up
>> to strip out the domain above?  I have seen that an issue from other
>> people but I have no clue as to where or how postfix does that except in
>> the master.conf above.
>> I also tried to use lmtptest (never had used it before so I looked at
>> the man page).
>> /etc # lmtptest -a user at domain2.tld -r domain2.tld -v host.domain2.tld
>> getaddrinfo: Servname not supported for ai_socktype
>> failure: Network initialization - can not connect to host.domain2.tld:lmtp
>> Thanks for the help.
>> -Adam
>> ----
>> Cyrus Home Page:
>> Cyrus Wiki/FAQ:
>> List Archives/Info:
> Adam,
> In your cyrus.conf file, uncomment the lmtp setting and make sure it 
> looks like this:
> lmtp            cmd="lmtpd -a" listen="localhost:lmtp" prefork=0 maxchild=20
> That way you dont have to authenticate with a real user. Also, here is 
> the way I tested with lmtptest and it worked for me:
> debian:~# lmtptest -p 2003 -u postdrop -v localhost
>  >mail from:<someuser at somedomain.tld>
>  >rcpt to:<user at domain2.tld>
>  >data
>  >test
>  >.
>  >quit
> you might get some error about invalid headers, thats b/c you don't have 
> the proper headers set, but it will deliver the mail anyway. Hope this 
> helps!

Here is my setting
lmtp cmd="lmtpd -a" listen="localhost:lmtp" prefork=0 maxchild=20
lmtpunix cmd="lmtpd" listen="/var/run/cyrus/socket/lmtp" prefork=0

If I just have lmtp without the lmtpunix I get this error:

relay=cyrus, delay=0.16, delays=0.05/0.03/0/0.08, dsn=4.3.0,
status=deferred (temporary failure. Command output: couldn't connect to
lmtpd: Connection refused_ 421 4.3.0 deliver: couldn't connect to lmtpd_ )

It only works with the lmtpunix.

my imap.conf has this line:
lmtpsocket: /var/run/cyrus/socket/lmtp

postfix/main.conf (This does not work)
mailbox_transport = lmtp:unix:/var/lib/cyrus/socket/lmtp
(this one does)
mailbox_transport = cyrus

lmtp unix - - - - - lmtp
cyrus unix - n n - - pipe
flags=R user=cyrus argv=/usr/sbin/cyrdeliver -e -m ${extension} ${user}

using lmtptest still gives me the same errors as before.


More information about the Info-cyrus mailing list