huge mail hangs lmtpd

Robert Mueller robm at
Wed Apr 11 20:33:28 EDT 2007

> I had again problems with an huge mail and lmtpd. I believe this is  
> caused by the sieve regex filtering of the huge mail.
> The lmtp uses about twice the size of the email of mem and all the
> cpu-time
> it can get. Then postfix gets a time out, but the lmtpd still keeps
> running
> and does not finish its work. At the next delivery attemt from postfix a
> new
> lmtpd gets huge and takes as much cpu time it can get, while the first  
> lmtp is still running and so on.

I'd double check that it's a regex issue. When you find a runaway lmtpd
process, use gdb to attach to it and get a stack backtrace.

> We run cyrus 2.3.8 and postfix 2.2.9 on a SLES10 system (pcre-6.4)
> I tried the rcpe-patch from fastmail to solve this problem, but
> delivering the
> same mail to the patched cyrus still showed the same behavior. Has  
> anyone else had this problem and had success with the patch from  
> fastmail?

The patch we created solved a similar but different problem. Basically I
saw certain emails with large headers interact with certain regexps and
cause the lmtpd process to grow to > 2G of memory and core dump.

So two things to do:
1. Use gdb to get a stack backtrace to confirm that it is a problem
inside a regexp
2. Double check that it actually is using the pcre library (check the
output of running ./configure to see that it actually finds the pcre
libraries on your system).


robm at
Sign up at for fast, ad free, IMAP accessible email

More information about the Info-cyrus mailing list