Some cyrus installation problems

David Korpiewski davidk at
Thu May 11 17:09:44 EDT 2006

I've built Cyrus 2.3.3 from source and have also built the latest 
postfix from source.   I'm having some weird problems, that I hope 
someone can help me with (OS is CentOS 4.3):

(1)  How do I get advanced logging going?  I have edited the 
syslogd.conf file and have set all imap and mail logging to be .*, and I 
also tried .info, no luck getting full information.     /var/log/maillog
local6.*      /var/log/imapd.log

In OSX the cyrus there would create a mailaccess.log file that would 
give me great information when things failed as they did in (2)

(2) My problem that relates to (1) is this:   I set up cyrus and 
configured SASL to work with our ldap server.  Using my mail client I 
can log into the system, but it always gives me this error:  "The 
current command did not succeed.  The mail server responded: MailBox 
does not exist."    I cannot find in the logs what is failing and where 
it is.  The mailstore directory is properly chowned and chmoded, 
although no user directories ever get created there. 

(3) I tried running cyradm to build a mailbox, but it failed because 
some directories were not in the right place originally.  After moving 
the Cyrus/IMAP directory up a level it got rid of those initial errors 
about not finding the .pm files and now I get this error:

Can't locate loadable object for module Cyrus::IMAP in @INC (@INC 
contains: /usr/lib/perl5/5.8.5/i386-linux-thread-multi 
/usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl/5.8.4 
/usr/lib/perl5/site_perl/5.8.3 /usr/lib/perl5/site_perl/5.8.2 
/usr/lib/perl5/site_perl/5.8.1 /usr/lib/perl5/site_perl/5.8.0 
/usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl/5.8.4 
/usr/lib/perl5/vendor_perl/5.8.3 /usr/lib/perl5/vendor_perl/5.8.2 
/usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/perl5/vendor_perl/5.8.0 
/usr/lib/perl5/vendor_perl .) at Cyrus/IMAP/ line 44
Compilation failed in require at Cyrus/IMAP/ line 44.
BEGIN failed--compilation aborted at Cyrus/IMAP/ line 44.
Compilation failed in require at Cyrus/IMAP/ line 60.
BEGIN failed--compilation aborted at Cyrus/IMAP/ line 60.
Compilation failed in require.
BEGIN failed--compilation aborted.

Can anyone help me?  Is this this right list for this?

Thank you

David Korpiewski                     Phone: 413-545-4319
Software Specialist I                Fax:   413-577-2285
Department of Computer Science       ICQ:   7565766
University of Massachusetts Amherst

More information about the Info-cyrus mailing list