John McMonagle johnm at
Fri Mar 24 13:45:27 EST 2006

Made some progress, seems it's more of a postfix issue but have not had 
any luck on the postfix newsgroup :(

This is what I have tried:

local_transport = lmtp:unix:/var/run/cyrus/socket/lmtp
virtual_alias_maps = hash:/etc/postfix/virtual

tried in  /etc/postfix/virtual:

test1            :include:/etc/postfix/lists/test1
test2    user1, user2, user3

test1 does not work
test2 does

I'm guessing that it's running in chroot environment and can not read
the include file.

I'm using  include files as it makes it a lot easier for the Human
Resource people to edit the lists.   I plan on changing the alias maps
to ldap  in a couple months rather not change twice.

Is there a place I can put the include files that will work and what 
will I give as
the path?
Or if I'm totally wrong get me know that too ;-)

Are alias_maps the only thing I need to deal with when changing the 
local_transport to lmtp?



John McMonagle wrote:

> Trying to get singleinstancestore to work.
> Using debian sarge with postfix and cyrus 2.1.18-1.
> Been searching through this list and goggle.
> maps are:
> alias_maps = hash:/etc/aliases
> local_recipient_maps = $alias_maps, ldap:/etc/postfix/, 
> hash:/etc/postfix/local-accounts
> local_destination_recipient_limit = 200
> lmtp_destination_recipient_limit = 200
> mailbox_transport = lmtp:unix:/var/run/cyrus/socket/lmtp
> If I set:
> local_transport = lmtp:unix:/var/run/cyrus/socket/lmtp
> It works but then the aliases do not work :(
> This sort of defeats the whole point as the local mailing lists are 
> defined in aliases.
> Saw some mention to use virtual_ maps but have not seen anything that 
> makes sense to me.
> Any pointers hints etc??
> Thanks
> John
>Cyrus Home Page:
>Cyrus Wiki/FAQ:
>List Archives/Info:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: johnm.vcf
Type: text/x-vcard
Size: 250 bytes
Desc: not available
Url :

More information about the Info-cyrus mailing list