2.3.3 replication

Marco Schirrmeister marco at schirrmeister.net
Sun Mar 19 19:43:06 EST 2006

On Mar 19, 2006, at 11:13 PM, Roland Pope wrote:

> ----- Original Message ----- From: "Marco Schirrmeister"  
> <marco at schirrmeister.net>
>> On Mar 2, 2006, at 10:52 PM, Patrick Radtke wrote:
>>> What happens if you use '-r' instead of '-u'
>> It happens the same.
>> I have tried all options. Every time the same error.
>>> I thought -u needed a list of users to follow it.
>>> -Patrick
>>> On Mar 2, 2006, at 4:39 PM, Marco Schirrmeister wrote:
>>>> Hello,
>>>> I try to setup replication according the docs. But it is not   
>>>> working at the moment.
>>>> If I try the following command as cyrus user "/usr/lib/cyrus- 
>>>> imapd/ sync_client -S centos4-vm2 -u" I get the following error  
>>>> messages.
>>>> Can not connect to server 'centos4-vm2'
>>>> syslog shows the following
>>>> sync_client[25660]: connect(centos4-vm2) failed: Invalid argument
>>>> Any hints?
> I had this same problem and it was caused by /etc/hosts having  
> point to my host name.
> Whan I changed /etc/hosts to put my hosts actual IP against the  
> hostname, it all started working as expected.

Great, thats it. Now here it works too.
On the slave I had already removed the hostname from the  
After I removed the hostname from the address on the master  
the sync process works fine.

with this line it works                localhost.localdomain localhost

with this line I had the error above.                centos4-vm1 localhost.localdomain localhost


> Cheers,
> Roland

More information about the Info-cyrus mailing list