Command-line reconstruct different from cyradm reconstruct?

Chris St. Pierre stpierre at
Mon Aug 21 09:35:58 EDT 2006

I have a number of users with quotas that are set correctly, but Cyrus
is confused about the amount of data they have.  For instance:

imap> lq user.jpublic
 STORAGE 0/307200 (0%)

If I run:

# su - cyrus -c "/usr/lib64/cyrus-imapd/reconstruct -rf user.jpublic"

nothing changes, and all remains as it was:

imap> lq user.jpublic
 STORAGE 0/307200 (0%)

But if I run reconstruct from cyradm, it works fine:

imap> reconstruct user.jpublic
imap> lq user.jpublic
 STORAGE 23140/307200 (7.53255208333333%)

Two questions:

1.  Why would this be?

2.  I need to reconstruct several thousand mailboxes thusly.  How can
    I script this?  Cyrus::IMAP::Admin doesn't appear to have a
    "reconstruct" method, and piping a text file into cyradm doesn't
    work because of the password prompt.  Other ideas?

I'm using the RHEL4 package of Cyrus IMAP v2.2.12.  Thanks!

Chris St. Pierre
Unix Systems Administrator
Nebraska Wesleyan University

More information about the Info-cyrus mailing list