Trouble with virtdomains

ogjunk-cyrus at ogjunk-cyrus at
Mon May 16 01:33:50 EDT 2005


I'm trying to configure Cyrus IMAP (cyrus-imapd-2.2.6-2.FC3.6 - Fedora
Code 3 package) to serve multiple domains.  I have it accept email from
Postfix when I don't use multiple (virtual) domains, but not with
"virtdomains: yes" in /etc/imapd.conf.

Here is what I have in /etc/imapd.conf:

... <standard stuff taken out> ...
sasl_pwcheck_method: saslauthd
sasl_mech_list: PLAIN
tls_cert_file: /usr/share/ssl/certs/cyrus-imapd.pem
tls_key_file: /usr/share/ssl/certs/cyrus-imapd.pem
tls_ca_file: /usr/share/ssl/certs/ca-bundle.crt

# OG: added
virtdomains: on
unixhierarchysep: 1
loginrealms: localdomain

If I comment out the last 3 lines, then I _can_ create new mailboxes
with cyradm (e.g. createmailbox user.otis.Trash).  However, I need this
server to serve email for multiple domains, so I need to be able to do
"cm user/otis at")

I've followed this:

But that results in this:

  cyradm -u cyrus localhost 143
  IMAP Password:
  localhost.localdomain> cm user.otis at
  createmailbox: Invalid mailbox name

I also tried this:

  localhost.localdomain> cm user/otis at
  createmailbox: Invalid mailbox name

I presume that's because Cyrus doesn't know about "".  How
do I tell it about ""?

I also read this:

But that had a few errors, so I gave up around half of the job. 
Perhaps Cyrus and cyradm would know about "" if I called
cyradm like this:

  cyradm -u cyrus 143

I tried that, but domain is not really configured yet
(DNS points to a different, old machine), so I can't really try that.

Any help would be appreciated.

Similar thread is here, but this doesn't seem to work for me:

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list