auth failure with cyrus, saslauthd, pam and ldap

Martin Hoffmann martin at
Sat May 21 17:17:23 EDT 2005

I found it !

stupid me ! Somehow my ldap index got messed up ! 
While adding samba schema to my ldap i accidently messed up my database, so i 
restored the whole ldap database from backup and did a clean adding of samba 
schema. However it seems i forgot to rebuild the index... Somewhat strange 
since "browsing" my ldap worked and OX itself could also use my ldap 
accounts ... !??
So "slapindex" solved all this :-)

Now i still have to investigate why my box doesnt resolve passwd/group 
information properly:
# getent passwd | grep testuser1
testuser1:x:1003:513:System User:/home/testuser1:/bin/bash
# ls -alh /home | grep testuser1
drwx------   2 1003  513 4,0K 21. Mai 14:00 testuser1

Should read
drwx------   2 testuser1 <some_group> 4,0K 21. Mai 14:00 testuser1

Strange !? My initial problem that login/su/chown with ldap users doesn't work 
still exists - but at least my imap works again :-) Whew !

Time to go to bed :-) I'll investigate the rest tomorrow ...

Thank you for your help !

Ferengi Rule of Acquisition Number 263:
Never allow doubt to tarnish your love of latinum. 
Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list