[SOLVED] my cyrus went crazy - "PANIC: DB_RUNRECOVERY: Fatal error" and others

Grzegorz Mucha grzegorz.mucha at gmail.com
Sun Mar 20 05:56:01 EST 2005


someone (langthang) from Gentoo forums showed me this solution:


although I did not upgrade db from 4.1 to 4.2 nor cyrus-imapd from 2.1 
to 2.2, which has those symptoms you described, I tried part of solution 
to recover databases:

# /etc/init.d/cyrus stop
$ sudo -u cyrus bash
$ cd /var/imap/
$ rm db/*
$ rm db.backup?/*
$ rm deliver.db
$ rm tls_sessions.db
$ /usr/lib/cyrus/ctl_mboxlist -d > mailboxes.txt
$ mv mailboxes.db mailboxes.db.old
$ /usr/lib/cyrus/ctl_mboxlist -u < mailboxes.txt
$ diff mailboxes.db*
Files mailboxes.db and mailboxes.db.old differ
# /etc/init.d/cyrus start

and it helped :).

Unfortunately I'm still worried about the system, as I don't know the 
reason of this failure. What had happend and why? And I still don't know 
what is the probability of same problems in near future?

Best regards, Grzegorz
Cyrus Home Page: http://asg.web.cmu.edu/cyrus
Cyrus Wiki/FAQ: http://cyruswiki.andrew.cmu.edu
List Archives/Info: http://asg.web.cmu.edu/cyrus/mailing-list.html

More information about the Info-cyrus mailing list