cyrus imapd 2.2.10 "disappears" on Solaris 8 host

Kirsch, Mathew (Matt) Mathew.Kirsch at
Fri Jan 21 13:57:15 EST 2005

I have a little bit more information.

It seems now that the master process "disappears" when I hit CTRL-C at the
command prompt?!!? For example, if I'm watching the process with Solaris's
truss command, and I hit CTRL-C to get out of the truss session, the master
process goes with it.

Since last night, I haven't hit CTRL-C in the console and the process has
been munching merrily along.

-----Original Message-----
From: Ian Delahorne [mailto:ian at]
Sent: Friday, January 21, 2005 12:46 PM
To: Kirsch, Mathew (Matt)
Cc: 'info-cyrus at'
Subject: Re: cyrus imapd 2.2.10 "disappears" on Solaris 8 host

Kirsch, Mathew (Matt) wrote:
> I just got cyrus imapd 2.2.10 running on a Solaris 8 host. Problem is, the
> master process keeps disappearing off the process list. It's not dumping
> core. It's not logging any problems. It's just going away.
> We need this to run reliably. Can anyone give me any suggestions as to how
> to debug the situation?

I've had that problem with 2.2.x on Solaris 9. I'm still not sure how I 
fixed it, as it seemed to be dependent on what libraries were in my 
LD_LIBRARY_PATH and a lot of other weird environment stuff (it worked 
when I had started after doing su, but not when run as a "real" root 
login / rc script).

I fixed stuff by building sasl, imapd and openssl as static as I could 
in their own little tree.


Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list