DB Errors

Derrick J Brashear shadow at dementia.org
Mon Apr 25 09:20:56 EDT 2005

On Sun, 24 Apr 2005, Daniel Hazelbaker wrote:

> Okay.  I'm hitting the annoyed state with this problem because it is feeling 
> close to being solved, but not quite!  The cwd of lmtpd process (and cyrus 
> itself) is the root directory.  I did a quick test of setting / to mode 777 
> (ya I know) and waited for an abnormal exit. Checked and still no core file. 
> Nor can I get the debug_command option in lmtpd to work to see what is going 
> on when it crashes.
> I have, however, been able to track it down to crashing when I try to deliver 
> to a non-existant mailbox.  For example, 'deliver user.blahblahblah' causes 
> it to crash in a BUSY state, same goes for 'deliver blah'. So I am closer, 
> but still can't figure out exactly why it is crashing, or not core dumping 
> for that matter.  Short of recompiling lmtpd to not fork, is there something 
> I am missing?  Here is my debug_command:
> /usr/bin/gdb /usr/lib/cyrus-imapd/%s %d

Well, if you can crash it, don't worry about the core, and just get a 
backtrace in gdb.
Cyrus Home Page: http://asg.web.cmu.edu/cyrus
Cyrus Wiki/FAQ: http://cyruswiki.andrew.cmu.edu
List Archives/Info: http://asg.web.cmu.edu/cyrus/mailing-list.html

More information about the Info-cyrus mailing list