Problem : unable to init duplicate delivery database ??

Martine James (02 23 23 71 31) martine.james at
Fri Apr 15 12:40:43 EDT 2005


I'm facing a quite odd (and worrying)  problem with my Cyrus server. 
System config: Solaris 9, Cyrus 2.2.9

I installed Cyrus one year ago and it used to work nicely with option "duplicatesuppression" as set by default (YES)

Things went wrong four days ago with this message:

Apr 14 12:00:04 pop3[7118]: [ID 729713 local6.error] opening /var/imap/tls_sessions.db: Not enough space
Apr 14 12:14:11 lmtpunix[10565]: [ID 729713 local6.error] DBERROR: opening /var/imap/deliver.db: Not enough space

Indeed, I checked ( twice) that no  partitions was full. I checked the 
number of inodes, number of files descriptors. everything's ok.

I tried to restart cyrus. "ctl_cyrudb -r" command never ends.
Mail distribution through lmtp is blocked.

Apr 14 12:14:12 lmtpunix[10569]: [ID 157947 local6.error] FATAL: lmtpd: unable to init duplicate delivery database

this a sendmail log:
Apr 14 14:28:37 postfix/lmtp[10031]: [ID 197553] 8D46E4D: to=<25002930 at>, orig_to=<************>, relay=none, delay=0, status=deferred (connect to /var/imap/socket/lmtp[/var/imap/socket/lmtp]: Connection refused)

command "cyr_expire -E 4" gave : cyr_expire: unable to init duplicate delivery database

I restored older deliver.db files to no avail.
I tried to suppress deliver.db: same behaviour

I changed "duplicatesuppression:" to NO : same behaviour

Any help would be really appreciated. Our mail server is down since 
then , and .... I don't like it.

Best regards

Martine James

Martine James   (Martine.James at
CRI - universite de Rennes 1 -  35042 Rennes cedex
tél : +33 2 23 23 71 31 - fax : +33 2 23 23 71 11

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list