Virtual domains in 2.2.3

Paul Wolstenholme wolstena at
Wed Sep 1 23:36:14 EDT 2004

Stupid mistake on my part but I still get the same error with:

localhost.localdomain> cm user.paul at
createmailbox: Invalid mailbox name

I'm also using saslauthd. I read in the archives that it may be 
necessary to have a ldap filter in  /etc/saslauthd.conf

ldap_filter: %U@%r

However when I do this I can no longer login to cyradm. I've tried 
logging in as:

  cyradm -u cyrus at localdomain localhost
  cyradm -u cyrus localhost

Neither method worked with the ldap_filter.

Any suggestions would be much appreciated.


On 1-Sep-04, at 7:06 PM, Ilya Krel wrote:

> i belive you have to use user.username at domain.tld
> On Wed, Sep 01, 2004 at 06:38:44PM -0700, Paul Wolstenholme wrote:
>> I'm using the the rpm version of cyrus v2.2.3-Red Hat 2.2.3-11
>> 2004/01/14 02:11:03 on Fedora Core 2. I have enable virtual domains 
>> but
>> I am unable to create new mailboxes with an "@". Is this a bug in
>> 2.2.3? There was a message in the archives that indicated it may be. 
>> If
>> so, is there a patch?.
>> Symptoms:
>> localhost.localdomain> cm paul at
>> createmailbox: Invalid mailbox name
>> I've tried /etc/imapd.conf with and without a defaultdomain and it
>> doesn't seem to make a difference.
>> Cheers,
>> Paul
>> ---
>> Cyrus Home Page:
>> Cyrus Wiki/FAQ:
>> List Archives/Info:

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list