Kent L. Nasveschuk knasveschuk at
Thu May 20 11:33:34 EDT 2004

First installation I used the stock Berkeley DBs. Then I tryed this
after installing BerkeleyDB 4.2.52. I used the following command line
options on configure:


It compiles and starts, but cyradm refuses to function. Running ldd on got:

ldd => /usr/lib/ (0x4001e000) => /lib/ (0x40032000) => /lib/ (0x40062000) => /lib/i686/ (0x42000000) => /lib/ (0x40136000) => /lib/ (0x40139000) => /lib/ (0x4014b000)
        /lib/ => /lib/ (0x80000000)

How do I force to find the libraries?

On Thu, 2004-05-20 at 10:57, Chris Harms wrote:
> I seem to recall getting this one on a few least one time 
> it wasn't finding my DB library.  Run ldd on in the perl 
> directory and see if it found DB.  If not you'll need to reconfigure 
> using some of the following configure options setting DIR as appropriate.
> --with-bdb=DIR          use Berkeley DB (in DIR) [yes]
> --with-bdb-libdir=DIR   Berkeley DB lib files are in DIR
> --with-bdb-incdir=DIR   Berkeley DB include files are in DIR
> Chris
> Kent L. Nasveschuk wrote:
> >Hello,
> >I have yet to get cyradm working on v 2.2.3 or the recent 2.2.4. Anyone
> >out there resolve the undefined symbol db_version problem that
> >accompanies cyradm?
> >
> >I've tried 2 installations on RedHat 8.0 and 1 on Slackware 9.0 with the
> >same problems. I've read a good deal of postings on this problem but
> >everyting up until now has not worked.
> >
> >
> >  
> >
Kent L. Nasveschuk <knasveschuk at>

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list