Problem w/ 2.2.4 and unixhierarchysep: yes

Ken Murchison ken at
Mon May 24 15:10:53 EDT 2004

Simon Matter wrote:

>>Bob Tito wrote:
>>>Hi all,
>>>Not trying to steal the tread ;-)
>>>But i hope additional/other info could be helpfull ?
>>>For the last couple of days i try to upgrade a FreeBSD 4.9 box from
>>>2.2.3 to 2.2.4 ...
>>>Luckally i did not have the problems described here, but NO WAY i was
>>>able to get sieve working with unixhierachysep and altnamespace
>>>enabled.. The scripts were just ignored.. reverting back to 2.2.3 solved
>>>the problem right away. I disabled altnamespace, but that didn't solve
>>>the problem, even after ajusting the scripts to te corrected mailbox
>>>location. I was not able to disable unixhierarchsep, because of live
>>>mailboxes ;-)
>>I can't reproduce this.  I just tested all 4 combinations of
>>altnamespace and unixhierarchysep and they all worked fine with 2.2.4.
> The hash_enumerate() function is also used by some other cyrus-imapd
> programs so I could think, without having a closer look, that it could
> also break other programs, right? I suggest testing it on a affected
> platform with the patch applied.

Obviously a fileinto needs to touch the quota code, so the hash problem 
is a possibility.  But I would suspect that if this were the case that 
it wouldn't be limited to just fileinto -- *any* message delivery would 
cause a problem.

> BTW, do you, the developers, plan to push out another release like 2.2.5
> if the patch discussed here fixes the problem? I just want to know whether
> I should wait for it before publishing updated rpms.

My guess would be that Rob will cut a 2.2.5 release once these issues 
are fixed.

Kenneth Murchison     Oceana Matrix Ltd.
Software Engineer     21 Princeton Place
716-662-8973 x26      Orchard Park, NY 14127
--PGP Public Key--
Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list