having trouble feeding Cyrus NNTP with fetchnews

Ben Poliakoff benp at reed.edu
Fri Jun 25 13:40:37 EDT 2004

Hello All,

I've recently upgraded from the 2.1.x branch to the 2.2.x branch of
cyrus-imapd (2.2.6 as of yesterday).  The upgrade was seamless.

One of the 2.2.x features I've been looking forward to has been the new
NNTP support.

I've created all the target mailboxes several times, both by hand and
also with the help of the "mknewsgroups" script.  All of the boxes have
(at minimum) the "anyone p" ACL set.

So far I'm having spotty luck feeding news from a remote INN server
into our cyrus imap server with the "fetchnews" command.  It's actually
worked only once.

Now when I run the following fetchnews command (starting over, having
cleared out the fetchnews.db file, and having freshly recreated all of
the target mailboxes to be fed):

    /usr/cyrus/bin/fetchnews -n -s my.server.name -w "news.bulletins*" \

I get the following message in my logs:

    Jun 25 10:19:15 my.server.name fetchnews[20623]: \
    fetchnews: remote.news.server offered 24; my.server.name rejected 24, \
    accepted 0, failed 0

I'd love to get those 24 articles.  I can't figure out why the cyrus
server is rejecting them.  Are there lingering message/article numbers
floating around in the duplicate.db?  What's the best way to debug
fetchnews issues?

Any suggestions would be gratefully accepted!


Cyrus Home Page: http://asg.web.cmu.edu/cyrus
Cyrus Wiki/FAQ: http://cyruswiki.andrew.cmu.edu
List Archives/Info: http://asg.web.cmu.edu/cyrus/mailing-list.html

More information about the Info-cyrus mailing list