Vanishing quota information

Rob Siemborski rjs3 at
Wed Jun 30 11:19:22 EDT 2004

On Wed, 30 Jun 2004, Simon Matter wrote:

> Unfortunately something is really broken and it reminds me the bug in
> 2.2.4 in hash.c. There was also a fildescriptor leak which should be fixed
> in 2.2.6, which is what I'm running.
> Unfortunately I can't seem to find what's going on but I know that quota
> -f still doesn't work as expected. I tried to run it today with the
> following result:
> Have a look at user.442vk which is a used mailbox with a freshly created
> quota.
> [root at imap01 root]# su - cyrus -c "/usr/lib/cyrus-imapd/quota -f"
> user.442vk: quota root user.442vk --> (none)
> user.442vk.Drafts: quota root user.442vk --> (none)
> user.442vk.Sent: quota root user.442vk --> (none)
> user.442vk.Trash: quota root user.442vk --> (none)

I can't replicate this unless it is related to the file descriptor "leak"

> user.gianeang: usage was 224158041, now 448316082
> user.gibbosim: usage was 93957125, now 187914250
> user.gigerkur: usage was 19138930, now 38277860
> user.gillearn: usage was 6575736, now 13151472
> quota: System I/O error Too many open files

This isn't actually a leak, we just aren't careful enough about how often
quota -f commits its transactions, so we actually hit the limit for file
descriptors, I think Ken is working on a patch to this now.


Rob Siemborski * Andrew Systems Group * Cyert Hall 207 * 412-268-7456
Research Systems Programmer * /usr/contributed Gatekeeper

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list