Sieve problems

Kevin Moschallski spyro at
Mon Jan 19 12:22:06 EST 2004

I'm running cyrus-imap 2.1.15 and exim 4.21 as MTA.My user database is a
mysql db so im using sasl.All is working fine i'm using 

unixhierarchysep: yes
altnamespace: yes

because i host this server for multiple domains.Know i ran into problems
using sieve with exim.I read that using sieve with exim is much easier
when using lmtp but when i try this i allways get:

2004-01-19 17:07:35 1AicsA-0000Vf-V5 ** spyro at
R=mysqluser_cyrus T=local_delivery_cyrus: SMTP error from remote mailer
after RCPT TO:<spyro at>: host localhost []:
550-Mailbox unknown.  Either there is no mailbox associated with
this\n550-name or you do not have authorization to see it.\n550 5.1.1
User unknown
2004-01-19 17:07:35 1AicsA-0000Vf-V5 Frozen (delivery error message)

i added -a switch to lmtpd in cyrus.conf but this doesn't work.
I think the problem is maybe with my altnamespace.If somebody could give
me his exim transport for cyrus it may could help me solving my problem.
Thanks for help in advance.

	Greets Kevin Moschallski

My exim.conf:


  driver = pipe
  command = /usr/cyrus/bin/deliver -a cyrus -m
${substr_1:${local_part_suffix}} -- $local_part\\@$domain
  user = cyrus
  group = mail
  message_prefix =
  message_suffix =

This one works but a can't get sieve to work with this.

   driver = smtp   
   protocol = lmtp     
   hosts = localhost   

and this one i tried acording to an howto but this rans me into the
problem that cyrus couldn't find the users mailbox.

More information about the Info-cyrus mailing list