telsey at starband.net telsey at starband.net
Wed Jan 7 17:34:34 EST 2004

Ok, I finally figured out the syntax that will work for me when using
ipurge.  Initially, I was trying to use run ipurge as:

./ipurge -f -d 7 user/*/mail/Trash

but nothing would happen.  I would execute the command, and was imediately
returned to the prompt.  Anyways, to make a long story short I tried the
following syntax and it works perfectly.

./ipurge -f -d 7 */mail/Trash

I hope this helps someone out.

>> telsey at starband.net wrote:
>>>>telsey at starband.net wrote:
>>>>>I know this question has been asked by others, but I was unable to
>>>>> find a solution in my research.  The problem I am having is with
>>>>> ipurge, and when I execute the command it executes, doesn't return
>>>>> an error, and doesn't remove the mail.
>>>>>We are running cyrus 2.2.1 beta, and we are using virtual domains,
>>>>> and the unixhierchysep instead of the standard dot (i.e.
>>>>> user/<useracct> instead of user.<useracct>).
>>>>>I am attempting to removed old mail from two folders with the
>>>>>following commands.
>>>>>ipurge -f -d 3 user/*/mail/Trash
>>>>>ipurge -f -d 7 user/*/mail/JunkMail
>>>>>My understanding is that the * would include all user accounts, and
>>>>> could be changed to something like username at domain.com (Our mail
>>>>> accounts contain the name and domain).
>>>>No, the domain is always appended to the end of the mailboxname.
>>>> Try:
>>>>ipurge -f -d 3 user/%/mail/Trash at domain.com
>>>>Kenneth Murchison     Oceana Matrix Ltd.
>>>>Software Engineer     21 Princeton Place
>>>>716-662-8973 x26      Orchard Park, NY 14127
>>>>--PGP Public Key--    http://www.oceana.com/~ken/ksm.pgp
>>> so if I were going to run it against all accounts, I would use a "%"
>>> instead of an "*"?  Ok, I will give it a try.
>> * matches everything, including the hierarchy separator.  % doesn't
>> match the separator, so you will only get
>> user/telsey/mail/Trash at domain.com and not
>> user/telsey/foo/bar/mail/Trash at domain.com
>>> For testing on an individual account, would the following work for a
>>> user with an account like telsey at domain.com.
>>> ipurge -f -d 3 user/telsey/mail/Trash at domain.com
>> Yes.
>>> Thanks for your help.  I just want to be extremely sure that I don't
>>> fubar the syntax and end up deleting mail that I had not intended to
>>> remove.
>> --
>> Kenneth Murchison     Oceana Matrix Ltd.
>> Software Engineer     21 Princeton Place
>> 716-662-8973 x26      Orchard Park, NY 14127
>> --PGP Public Key--    http://www.oceana.com/~ken/ksm.pgp
> Ok, I tried the individual ipurge command above (ipurge -f -d 3
> user/telsey/mail/Trash at domain.com), but it did not remove anything.  It
> executed and imediately went back to the prompt with no error or
> anything else.  I definately have old items in my Trash.
> I am executing the command from the command line as the cyrus account.
> su - cyrus
> cd /usr/cyrus/bin
> ./ipurge -f -d 1 user/telsey/mail/Trash at domain.com
> Does ipurge log any information anywhere?  Is there an updated version
> of the program?  I'm ready, and willing to try anything.

More information about the Info-cyrus mailing list