Problem building Cyrus SASL 2.1.17

Nikola Milutinovic Nikola.Milutinovic at
Fri Feb 13 08:15:59 EST 2004

Hi all.

I must say I'm puzzled. This is the first time I run into a problem like this 
with SASL.

OS: Tru64 UNIX 4.0D
CC: DEC CC + latest set of GNU tools (make, automake, autoconf,...)

Configure options were:


Configure goes well (except for tieing up to Berkeley DB 4.1, instead of 4.2, 
but I'll sort it out later), recognizing all it should. Running "make" (tried 
both GNU and DEC), fails shortly, with an error:

mv -f .libs/plugin_common.lo plugin_common.o
(cd . && ln -s plugin_common.o plugin_common.lo)
rm -f getaddrinfo.lo getnameinfo.lo snprintf.lo
cd ../lib; gmake getaddrinfo.lo getnameinfo.lo snprintf.lo
gmake[3]: Entering directory `/home/r/root/build/cyrus-sasl-2.1.17/lib'
gmake[3]: *** No rule to make target `getaddrinfo.lo'.  Stop.
gmake[3]: Leaving directory `/home/r/root/build/cyrus-sasl-2.1.17/lib'
gmake[2]: *** [getaddrinfo.lo] Error 2
gmake[2]: Leaving directory `/home/r/root/build/cyrus-sasl-2.1.17/plugins'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/home/r/root/build/cyrus-sasl-2.1.17'
gmake: *** [all] Error 2

If I understand the course of action here:

1. "make" goes into "./plugins" dir
2. then it tries to satisfy "COMPAT_OBJS = getaddrinfo.lo ..."
3. for that it does "cd ../lib; $(MAKE) $(COMPAT_OBJS)"
4. it fails, not finding source files for build

Now, the strange things:

1. "getaddrinfo.c" and "getnameinfo.c" are in "./saslauthd/", not in "./lib/"
2. there is no trace of "snprintf.c" ANYWHERE in the package.

What is wrong with this picture?


Home Page:
List Archives/Info:

More information about the Info-cyrus mailing list