Cyrus Login

Andreas andreas at
Thu Aug 5 09:57:54 EDT 2004

On Thu, Aug 05, 2004 at 08:51:02AM -0500, Cory D. Wiles wrote:
> I looked at the bug report and the problem is VERY similar to mine. Also 
> I tried to force the method and got the same error that you received did:
> $cyradm --user cyrus --auth DIGEST-MD5 stasis
> Password:
> $cyradm: cannot authenticate to server with DIGEST-MD5 as cyrus

That's because you don't have digest-md5 setup properly. The segfault happens
whenever gssapi comes into play here and is not configured, that is, it fails.

If no mechanisms are specified, cyradm will try several, in order, including
gssapi, where the segfault occurs if gssapi is not configured.

So, to sum things up, you may want to remove the gssapi sasl plugin from your
sistem for now and configure digest-md5 or some other mechanism. To use
digest-md5 is not that hard, basically:
- saslpasswd2 -c <yourname>
- check that /etc/sasldb2 is created
- check permissions on that file: the cyrus-master daemon has to be able to read

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list