ctl_cyrusdb DBERROR (urgent)

Didi Rieder adrieder at sbox.tugraz.at
Tue Aug 10 08:29:27 EDT 2004

--On Tuesday, August 10, 2004 08:21:34 AM -0400 Igor Brezac 
<igor at ipass.net> wrote:

> On Tue, 10 Aug 2004, Didi Rieder wrote:
>> --On Tuesday, August 10, 2004 05:33:11 PM +0800 Craig Ringer
>> <craig at postnewspapers.com.au> wrote:
>>> On Tue, 2004-08-10 at 17:09, Didi Rieder wrote:
>>>> Hi again,
>>>> I'm still stuck with my problem, is there nobody who can give me a
>>>> hint? I'd appreciate it very much.....
>>> Well, you might want to make sure you're using the right db format for
>>> your actual on-disk database (ie skiplist or bdb). It's also a good idea
>>> to run db_verify if it's a Berkley DB in case there's some BDB
>>> corruption.
>> Thanks for your answer. I checked the db types and they should be fine.
>> We  didn't use any of the db files of the olf server because we
>> transfered the  mailboxes via mailutil, so the imapd should have created
>> the right types  according to the imapd.conf file.
>> It is also interesting, that if I run ctl_cyrusdb as user cyrus manually
>> no  errors show up, not in the logs and not on stderr/stdout....
>> This is what I see in the logs, when I run it manually:
>> Aug 10 12:49:33 sbox ctl_cyrusdb[19828]: [ID 702911 local6.notice]
>> checkpointing cyrus databases
>> Aug 10 12:49:33 sbox ctl_cyrusdb[19828]: [ID 127214 local6.notice] done
>> checkpointing cyrus databases
>> BTW: The OS is Sun/Solaris 9 if it matters at all...
> What version of Sleepycat db do you use?

db-4.2.52 with patch 1 and patch 2 from Sleepycat....


Didi Rieder
adrieder at sbox.tugraz.at
PGPKey ID: 3431D0B0
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : https://lists.andrew.cmu.edu/mailman/private/info-cyrus/attachments/20040810/3e6a6034/attachment.bin

More information about the Info-cyrus mailing list