Problem solved: Default domain returns namespace NIL when virtual domains enabled

Igor Brezac igor at
Thu Aug 19 12:13:07 EDT 2004

On Thu, 19 Aug 2004, Erik Norgaard wrote:

> On Thu, 19 Aug 2004, Erik Norgaard wrote:
>> It turns out that imap defaultdomain works perfectly - but only on
>> loopback interface (now that's really usefull :-))
> Yup, and really strange! Why would it only work on the loop back
> interface? I am getting increasinly embarrased because it turned
> out that the problem was local.
> Aparently, cyrus-imap does a reverse lookup of the ip on the inter-
> face that recieves the connection. This must resolve to a host
> under the defaultdomain.
> So, adding the line '' to /etc/hosts
> solved the problem.
> This may mean that new problems will arise if you have more do-
> mains/hostnames in your hostsfile. Say eth0 belongs to
> while eth1 belongs to, or you specify
> and because boths should map to the same ip. I
> do not know if you will be able to serve both domains. So, beware
> what you put in your hosts file.

This is done on purpose so that clients do not have to use fully 
qualified userids for authentication.  This can be useful when you want to 
merge email servers and/or you do not want your clients to change their 
login information.

> I have no idea why one would implement such a restriction, since
> there can only be one default domain, the namespace is implicitly
> given if not part of the login realm. Anyone?

Use virtdomains: userid, but you will need to use a fully qualified userid 
for authentication.

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list