Joakim Ryden jryden at
Sat Nov 15 07:30:40 EST 2003

Hey everyone -

this (or variations of this) has worked for me so many times in the 
past that I never considered it a hump to get over but this time I'm 

I can't get realm auth working with 2.2.2-BETA (and SASL 2.1.15). I add 
a user like so:

saslpasswd2 -c jryden

test it with

imtest -a jryden localhost

This user is able to log in to the IMAP server no problem.  I add 
another user:

saslpasswd2 -u -c test

test it with

imtest -a test -r localhost

and various variations of the imtest command. No dice:

Nov 15 04:16:32 cyrus imap[12149]: badlogin: localhost [] 
CRAM-MD5 [SASL(-13): user not found: no secret in database]

(I tried several mechs with the same result (and the plugins are all 

What did I miss??

My imapd.conf:

configdirectory: /var/imap
partition-default: /var/spool/imap
sievedir: /var/spool/sieve
altnamespace: yes
virtdomains: yes
userprefix: Other Users
sharedprefix: Shared Folders
admins: cyrus
allowanonymouslogin: no
sasl_pwcheck_method: auxprop
sasl_auxprop_plugin: sasldb
duplicatesuppression: yes
singleinstancestore: yes
sendmail: /usr/sbin/sendmail


More information about the Info-cyrus mailing list