Cyrus IMAP 2.1.12 and Berkeley 4.1.25

Joe Rhodes lists at
Thu May 1 22:20:04 EDT 2003

Hello all:

My apologies for what seems to me to be kind of a dumb question, but I 
just can't seem to get around this.

I can't seem to get past the ./configure with Cyrus IMAP.  It always 
complains when it's looking for db_create in the Berkeley db.h file.

I've uninstalled the db4 rpms that RedHat 9 ships with (db4, db4-devel, 
and db4-util) and compiled my own version of Berkeley DB 4.1.25, using 
--prefix=/usr as the only compile option.  I had no errors in the build 
process.   I need to use 4.1.25, since OpenLDAP requires it.  
(OpenLDAP, BTW, compiles and links fine against the library.)  I'd 
prefer to use this version also for Cyrus IMAP and SASL if I can.  
(Havn't gotten around to the latter yet).  From what I've read, Cyrus 
IMAP and SASL can use the Berkeley 4.1.25 library.

The configure script finds the db.h file, and then proceeds to check 
for db_create in db-4.1, db4.1 and so on.  It doesn't find it and then 
gives the message that I should install Berkeley DB from

I've tried putting Berkeley DB in its own directory, 
/usr/local/Berkeley and use the --with-dbdir --with-db-libdir and 
--with-db-incdir to point there, that didn't work.  I've tried using 
those same ./configure flags to point at my /usr/lib and /usr/include 
directories.  No dice.  I've searched my hard drive to make sure there 
wasn't some rogue db.h file sitting around lousing things up.  Nothing 
but the one in the /usr/include directory and the Berkeley DB source 

So how does one get this to ./configure and compile?  Am I missing 
something obvious?  I didn't see anything in the FAQ or in the archives 
in the mailing list.

Quick stats:

Dual P3 machine
RedHat 9
gcc-3.2.2-5 (from rpm)
Berkeley DB 4.1.25 from

Thanks in advance!


More information about the Info-cyrus mailing list