Cyrus IMAP 2.1.12 and Berkeley 4.1.25

Joe Rhodes lists at
Fri May 2 12:14:24 EDT 2003


Thanks for the pointers, but it doesn't seem to help.

In my /usr/lib directory, I have the following:

[root at Phoenicia lib]# ll libdb*
-rwxr-xr-x    1 root     root        55096 Feb 11 00:30
-r--r--r--    1 root     root       751944 May  1 11:09 libdb-4.0.a
-r--r--r--    1 root     root          724 May  1 11:09
-r-xr-xr-x    1 root     root       603694 May  1 11:09
-rw-r--r--    1 root     root       889280 May  1 11:14 libdb-4.1.a
-rw-r--r--    1 root     root          703 May  1 11:14
-rwxr-xr-x    1 root     root       719667 May  1 11:14
lrwxrwxrwx    1 root     root           12 May  1 11:14 
lrwxrwxrwx    1 root     root           11 May  1 11:14 libdb.a 
lrwxrwxrwx    1 root     root           12 May  1 11:14 
lrwxrwxrwx    1 root     root           11 Apr 16 23:35 

All of the ones marked May 1st are the ones that I've compiled myself.  
To be sure I wasn't missing something, I moved the and 
libdb-4.0.* files out of the directory so I would only have the 4.1.25 
libs there.  No joy.

Now here's an interesting little fact that I just discovered.  I've 
downloaded and compiled the DB 4.0.14 package--the same version as the 
rpm that was installed from RedHat.  When I compile that and install it 
into the same directory, /usr/, I get the same error message.

So that leads me to believe that it has something to do with the way 
I've compiled Berkeley DB, both with version 4.0.14 and with 4.1.25.  
Whatever I've done, Cyrus IMAP doesn't seem to like it.  OpenLDAP does, 
or at least doesn't complain about it.

Again, BerkeleyDB packages were compiled with --prefix=/usr flag.  I've 
looked through the sleepy cat docs, but I don't see anything terribly 
obvious that jumps out at me.  If anyone has some suggestions?  One 
thing I'm going to try, just out of desperation, is playing with 
different mutexes.  Seems to be there's some mention about using Posix 
mutexes having an effect on DBenv-->open.  But I'm just throwing darts 
with a blindfold on here.

If I might ask, please CC me directly, as I get the digested version of 
the list.  (Ok, that last part just sounds wrong...  :)

Once again, thanks in advance!

On Friday, May 2, 2003, at 10:21  AM, Christian Schulte wrote:

> Joe Rhodes wrote:
>> Hello all:
>> My apologies for what seems to me to be kind of a dumb question, but 
>> I just can't seem to get around this.
>> I can't seem to get past the ./configure with Cyrus IMAP.  It always 
>> complains when it's looking for db_create in the Berkeley db.h file.
>> I've uninstalled the db4 rpms that RedHat 9 ships with (db4, 
>> db4-devel, and db4-util) and compiled my own version of Berkeley DB 
>> 4.1.25, using --prefix=/usr as the only compile option.  I had no 
>> errors in the build process.   I need to use 4.1.25, since OpenLDAP 
>> requires it.  (OpenLDAP, BTW, compiles and links fine against the 
>> library.)  I'd prefer to use this version also for Cyrus IMAP and 
>> SASL if I can.  (Havn't gotten around to the latter yet).  From what 
>> I've read, Cyrus IMAP and SASL can use the Berkeley 4.1.25 library.
> Yes! You can link both against db-4 !
>> The configure script finds the db.h file, and then proceeds to check 
>> for db_create in db-4.1, db4.1 and so on.  It doesn't find it and 
>> then gives the message that I should install Berkeley DB from 
> Where do you have files ? Does your linker search 
> that path during linking ? It seems that cannot be found 
> ! Do you have ? If not: Make a link from to 
>> I've tried putting Berkeley DB in its own directory, 
>> /usr/local/Berkeley and use the --with-dbdir --with-db-libdir and 
>> --with-db-incdir to point there, that didn't work.  I've tried using 
>> those same ./configure flags to point at my /usr/lib and /usr/include 
>> directories.  No dice.
> So you only have and not I think !
> Christian

More information about the Info-cyrus mailing list