Sieve problems

Craig Graham craig at
Tue May 6 06:41:04 EDT 2003

I have Cyrus Imap installed, using the RPMs supplied with Mandrake8.1. The
version appears to be 2.1.4. I am using "PLAIN" authorisation.

All has been fine for the past year which makes me reluctant to upgrade to
the latest version and risk breaking anything- I don't have a great deal of
time to play with the box- but I'm now wanting to get Sieve working, and
have hit a bit of a wall.

I've tried Sieveshell and installsieve- both segfault on connecting. I've
tried the web one, but it refuses to accept any login. So I tried playing
with the daemon, and have found something that appears to be wrong when
first connecting;

"IMPLEMENTATION" "Cyrus timsieved v1.1.0"
"SIEVE" "fileinto reject envelope vacation imapflags notify subaddress

In similar dumps in other messages I've seen, there has been a list of
authentication mechanisms between "IMPLEMENTATION" and "SIEVE". So it seems
Timsieved isn't aware of any mechanisms. How do I make it aware of "PLAIN"?

Here are the two config files if necessary.


# standard standalone server implementation

  # do not delete this entry!
  recover       cmd="ctl_cyrusdb -r"

  # this is only necessary if using idled for IMAP IDLE
#  idled                cmd="idled"

# UNIX sockets start with a slash and are put into /var/lib/imap/sockets
  # add or remove based on preferences
  imap          cmd="imapd" listen="imap" prefork=5
  imaps         cmd="imapd -s" listen="imaps" prefork=1
  pop3          cmd="pop3d" listen="pop3" prefork=3
  pop3s         cmd="pop3d -s" listen="pop3s" prefork=1
  sieve         cmd="timsieved" listen="sieve" prefork=0

  # at least one LMTP is required for delivery
  lmtp          cmd="lmtpd -a" listen="lmtp" prefork=0
  lmtpunix      cmd="lmtpd -a" listen="/var/lib/imap/socket/lmtp" prefork=1

  # this is only necessary if using notifications
#  notify       cmd="notifyd" listen="/var/lib/imap/socket/notify"
proto="udp" p

  # this is required
  checkpoint    cmd="ctl_cyrusdb -c" period=30

  # this is only necessary if using duplicate delivery suppression
  delprune      cmd="ctl_deliver -E 3" period=1440

  # this is only necessary if caching TLS sessions
  tlsprune      cmd="tls_prune" period=1440


configdirectory: /var/lib/imap
partition-default: /var/spool/imap
admins: cyrus
allowanonymouslogin: no
sieveuserhomedir: no
sievedir: /var/lib/imap/sieve
sendmail: /usr/sbin/sendmail
hashimapspool: true
sasl_pwcheck_method: saslauthd
sasl_mech_list: PLAIN
#tls_cert_file: /var/lib/imap/cyrus-imapd.pem
#tls_key_file: /var/lib/imap/cyrus-imapd.pem

Dr. Craig Graham, Software Engineer
Advanced Analysis and Integration Limited, UK.

More information about the Info-cyrus mailing list