sieve: "Invalid mailbox name"

Eric Ewanco eje at
Thu May 8 11:27:48 EDT 2003

I'm trying to set up sieve to automatically file mail from/to certain 
addresses into folders.  I followed the example script 
<> and set up 
the following script:

require "fileinto";

if address :contains :all ["apparently-to", "to", "cc", "bcc", "sender"] 
  fileinto "INBOX.Apologia";}

I put it on the server just fine using sieveshell.  When I deliver a 
test message, it goes in my INBOX and the syslog says:

May  6 20:48:04 polycarp lmtpd[11331]: sieve runtime error for eje id 
(null): Fileinto: Invalid mailbox name

I tried changing the mailbox from INBOX.Apologia to user.eje.Apologia, 
and that yields a "Mailbox does not exist" error, so the mailbox is 
correct, there is just something about it that it doesn't like.  I have 
"all" ACL permissions for my user on that mailbox.  I can see the 
mailbox just fine in my MUA and can put messages into it.  I do not have 
unixhierarchysep set.  I've tried at least one other mailbox with the 
same result, although if I specify the mailbox "INBOX" it delivers the 
message without complaint.  Any idea what's going on?

I ran the test script in the Cyrus documentation under "Installing 
Sieve" and it kinda works (it doesn't accept the message, but it doesn't 
reply with an error message, either). 

Eric Ewanco

More information about the Info-cyrus mailing list