imap not responding/cyradm hangs

Andy Litzinger alitzinger at
Mon May 19 21:57:14 EDT 2003

Hi all,
  I am trying to troubleshoot my Postfix+mySql+Cyrus Imap/Sasl+web-cyradm+RH 
7.2 install.  I have been following Luc's HowTo to the best of my ability ( i have some 
pre-existing conditions to contend with), but have not been able to get everything to 
  In trying to troubleshoot from the bottom up i have discovered that although cyrus 
will start, imap does not seem to be properly answering requests.  At the end of Luc's 
and Andrew's how to's they instruct you to test imap functionalicty via the CLI 
cyradm.  I have added my cyrus user with the saslpasswd2 util and tried to connect 
with the following string:
# cyradm --user cyrus --server localhost --auth plain
 but when I do this cyradm never prompts me for a password and appears to hang.  
I've let it sit for a  good 10 mins and no luck.

The end of the Managing IMAP O'reilly book suggests the following steps  to test the 
IMAP server:
 # telnet localhost imap
which is supposed to connect you to the imap server, display the banner and allow 
you to enter cmds such as . noop which should return status of . OK Completed.

When I try, I connect, but get no banner.  and when I try to enter commands I don't 
get any response.  Following the troubleshooting steps I have verified imap 143/tcp in 
the /etc/services, Step 2 (inetd) is not applicable because IMAP is controlled through 
the cyrus rc script and not xinetd. 
Step 3 is interesting because it asks you to make sure that /usr/cyrus/bin/imapd is 
owned by cryus:mail.  I have a discrepancy here; all files in my /usr/cyrus bin are 
root:root.  I tried changing the ownership of imapd to cyrus and restarting cyrus, but 
this did not change anything.  I didn't see anything in Luc or Andrew's how to about 
changing permissions on these files anway...

Has anyone had and solved this issue?  Any ideas for other things for me to check to 
track down the origin of the problem?

I also have been disappointed to find little to no log entries, is there a setting i can 
use to produce more verbose logs?


Here is a more detailed system summary:
RH 7.2 with kernel 2.4.7-10 (yes i know it's old)

>From Source:
Postfix 2.0.9
pam-mysql 0.5
Cyrus Imap 2.1.12
Cyrus Sasl 2.1.12
openssl 0.9.6.g
apache 1.3.27
php 4.31

More information about the Info-cyrus mailing list