Delivery not working

Etienne Goyer etienne.goyer at
Tue May 27 16:10:02 EDT 2003

A few suggestions ...

Have you had a look at /var/log/maillog ?

I suggest you add the the following line to /etc/syslog.conf :

local6.debug        /var/log/imapd.log

and that you do the following commands :

# touch /var/log/imapd.log
# service syslog restart

After that, try to flush you mail queue ("sendmail -q") and check
/var/log/imapd.log for revelant messages.  If you don't see a line
from the lmtpd process, your sendmail does not even try to deliver.

I can't help you with sendmail, but with postfix you need the following
line in /etc/postfix/ :

mailbox_transport = lmtp:unix:/etc/lmtpproxy

Another thing to look for (just to be sure) : is lmtpd running ?

On Tue, May 27, 2003 at 06:38:03PM +0200, belgabor at wrote:
> Hello,
> I have trouble with getting sendmail delivery to work properly on my cyrus
> IMAP (Redhat 7.3) server (tried both 2.1.x and 2.2). I installed it fine on a
> diffrent server (also RedHat 7.3) so I'm quit puzzled why it doesnt want to
> work here. The worst trouble is I cannot find any error message anywhere, just
> the mail doesn't show up in the INBOX, it gets stuck in the mail queue
> (/var/spool/mqueue) and I'm out of options what do do next or how to debug
> (admittedly I'm quite new to unix/linux mailing). Any hints would be appreciated.
> Cheers
> Tobias
> P.S: I tried do lmtp delivery both via socket and TCP, but neither worked.
> -- 
> +++ GMX - Mail, Messaging & more +++
> Bitte lächeln! Fotogalerie online mit GMX ohne eigene Homepage!

Etienne Goyer                    Linux Québec Technologies Inc.       etienne.goyer at

More information about the Info-cyrus mailing list