Weird pop3d hang problem (fd blocked?!)

foobar foobar at
Fri May 30 11:09:49 EDT 2003


Today our mailserver jammed all its pop3d processes and trace said
"read(10," and it was blocking there.

imap-processes were served fine and db-files were ok (DB4).

Then I restarted all processes and checked db-files and tried to debug.

Then I was desparate and I restarted whole system and after init
everything was fine again (pop3 was served without that jam.)

titus at foo titus ~%> telnet 0 110
Connected to 0.
* Hanging here (waiting banner) *
Escape character is '^]'.
telnet> quit
Connection closed.

^ No banner even.

Imap(s) (working fine, banner prints)

Escape character is '^]'.
* OK foo Cyrus IMAP4 v2.1.11 server ready

Authentication and all operations worked fine on imap's side.

I just wonder what caused this kind block in pop3-processes or what
_could_ cause this kind problem..

Kernel: 2.4.18-14 / GNU Linux
I am using PAM (via saslauthd) for pop and imap.

No, I didn't check if I was out of entropy (random).
Log (syslog) said nothing what caused this problem and didn't even give
any hint.

Best regards,

More information about the Info-cyrus mailing list