Sasl-2.1.13 with heimdal kerberos implementation does not comple

Rob Siemborski rjs3 at
Wed Jun 18 09:30:59 EDT 2003

On Wed, 18 Jun 2003, Dmitry Novosjolov wrote:

> 1. the configure script does not determine correctly the implementation of my
> kerberos libraries. I installed heimdal but it thinks it's MIT. I think this
> machine never knew anything like MIT kerberos. I've solved this by hacking
> the part of configure which does it: I just forced the type to be always
> heimdal by default, by removing some lines from configure and replacing mit
> with heimdal in $gss_impl="mit".
> Seems like this works now.

I highly doubt this will actually work.

Did you manage to look at config.log and find out why the link test was

> 3. saslauthd does not compile. It says that it cannot be linked due to lack of
> some libraries, but I think in my configuration I will not need the
> saslauthd, so I think that it can be skipped and does not have influence to
> library. Correct ?

Yup, just don't compile saslauthd (but I suspect if you can find out why
the configure test is failing, that will also result in saslauthd linking


Rob Siemborski * Andrew Systems Group * Cyert Hall 207 * 412-268-7456
Research Systems Programmer * /usr/contributed Gatekeeper

More information about the Info-cyrus mailing list