problems with imap and imsp installation

Ted Fines fines at
Thu Jun 26 11:53:48 EDT 2003


The SASL/IMAP/IMSP installation is about as difficult as any I have run 
across.  While the amount of work on Project Cyrus is very impressive, 
thorough documentation of it just doesn't seem to be available.

If you do manage to get a SASL/IMAP/IMSP installation running, maybe you'd 
care to put together a nice HOW-TO for the rest of us?

I gave up trying to use the new IMSP that uses SASL.  I simply could not 
get it to compile on ANY platform (Solaris, Linux, FreeBSD were tried).  I 
use an older version with a patch that allows it to authenticate to the 
imap server.  Still, the imsp daemon crashed very frequently on Solaris 8. 
I recompiled it -- exactly the same way -- on FreeBSD, and it is very 

Just try to get it all working with LDAP too!

You wrote:
> Surely, thousands of people must have installed the cyrus imap/imsp
> combination on  Solaris 8 without anything like this trouble?

I think that's optimistic.  The number of imsp installations *might* be in 
the triple digits, but I doubt even that.  I have absolutely to 
quantitative data to back up that statement, of course! :)

You can get autoconf, autoheader, etc. packages from 
<>, but you probably already knew that.


--On Thursday, June 26, 2003 4:26 PM +0100 Phil Chambers 
<P.A.Chambers at> wrote:

> I have just installed a new Sun box running Solaris 8 and expected that
> installing  the cyrus IMAP and IMSP packages would be simple!
> First I installed BerkleyDB.3.3 and Perl and they went OK.
> Then I picked up cyrus-sasl -2.1.13 and installed that once I sorted out
> the  --with-... and --disable-... options I needed.  Not too bad.
> Then cyrus-imapd-2.1.13 and that seemed to install OK, again, once I had
> sorted out  the configure options I needed.  The IMAP and POP server side
> seem to run and  respond to telnet connections and imtest worked.
> I then tried to use cyradm to add some users and that is where it went
> downhill! I get the following
> Can't load
> '/usr/perl5/site_perl/5.005/sun4-solaris/auto/Cyrus/IMAP/' for
> module Cyrus::IMAP: perl: fatal: relocation error: file
> /usr/perl5/site_perl/5.005/sun4-solaris/auto/Cyrus/IMAP/ symbol
> sasl_client_init: referenced symbol not found at
> /usr/perl5/5.00503/sun4-solaris/ line 169.  at
> /usr/perl5/site_perl/5.005/sun4-solaris/Cyrus/IMAP/ line 44 BEGIN
> failed--compilation aborted at
> /usr/perl5/site_perl/5.005/sun4-solaris/Cyrus/IMAP/ line 44.
> BEGIN failed--compilation aborted at
> /usr/perl5/site_perl/5.005/sun4-solaris/Cyrus/IMAP/ line 60.
> BEGIN failed--compilation aborted.
> As far as I can make out, this is a dynamic library problem, but I have
> completely  failed to find a cure for it.
> Help with that will be most welcome.
> I then moved on to IMSP and downloaded cyrus-imspd-v1.6a3 and tried to
> build that.   This failed because there is no present!  I
> looked at v1.5.28 and that  has the same problem.  On further reading I
> found that both these versions need  version 1.5.x of sasl.  I had just
> installed 2.1.13 because that is what IMAP needs!  So I downloaded
> cyrusimsp from cvs to get a version which would work with 2.1.13.   It
> now seems I need autoconf (and aclocal and autoheader?) before I can make
> more  progress with that.
> Will this never end?
> Surely, thousands of people must have installed the cyrus imap/imsp
> combination on  Solaris 8 without anything like this trouble?
> Phil.
> ---------------------------------------
> Phil Chambers (postmaster at
> University of Exeter

More information about the Info-cyrus mailing list