Cyrus Hell

Eric Naeseth cloaked at
Tue Jul 22 22:59:12 EDT 2003

I've been trying to get Cyrus IMAPD 2.1.14 working on my system for a
couple days now with no success. 

I've used the configure line:
./configure --with-auth=unix --with-dbdir=/usr/local/BerkeleyDB.4.1

I had also tried this line earlier, and wound up in the same situation
as I have now: I can connect to my server on IMAP or POP3, but the
server sends nothing back.  I tried configuring with Kereberos, but
configure failed to locate it, even when I told it to look in
/usr/include (where it is).

All the cyrus executables are executable.

standard standalone server implementation

  # do not delete this entry!
  recover       cmd="ctl_cyrusdb -r"

  # this is only necessary if using idled for IMAP IDLE
#  idled                cmd="idled"

# UNIX sockets start with a slash and are put into /var/imap/sockets
  # add or remove based on preferences
  # --- tried with and without the absolute paths ---
  imap          cmd="/usr/cyrus/bin/imapd" listen="imap" prefork=5
  imaps         cmd="/usr/cyrus/bin/imapd -s" listen="imaps" prefork=1
  pop3          cmd="/usr/cyrus/bin/pop3d" listen="pop3" prefork=3
  pop3s         cmd="/usr/cyrus/bin/pop3d -s" listen="pop3s" prefork=1
  sieve         cmd="/usr/cyrus/bin/timsieved" listen="sieve" prefork=0

  # at least one LMTP is required for delivery
#  lmtp         cmd="lmtpd" listen="lmtp" prefork=0
  lmtpunix      cmd="lmtpd" listen="/var/imap/socket/lmtp" prefork=1

  # this is only necessary if using notifications
#  notify       cmd="notifyd" listen="/var/imap/socket/notify"
proto="udp" prefork=1

  # this is required
  checkpoint    cmd="ctl_cyrusdb -c" period=30

  # this is only necessary if using duplicate delivery suppression
  delprune      cmd="ctl_deliver -E 3" at=0400

  # this is only necessary if caching TLS sessions
  tlsprune      cmd="tls_prune" at=0400

postmaster: postmaster
configdirectory: /var/imap
partition-default: /var/spool/imap
allowplaintext: yes
sasl_mech_list: PLAIN
autocreatequota: 10000
reject8bit: no
quotawarn: 90
timeout: 30
sasl_pwcheck_method: pwcheck # *** Tried saslauthd and pwcheck.
                             # saslauthd *is* running
sievedir: /usr/sieve
sendmail: /usr/sbin/sendmail
sieve_maxscriptsize: 32
sieve_maxscripts: 5

More information about the Info-cyrus mailing list