master (resolve_port) segmentation fault

warren at warren at
Wed Dec 10 09:54:12 EST 2003

Greetings all

The latest cyrus and sasl (stables, compiled) on a debian3 (fully updated) is 
giving me a segmentation fault at


in the resolve_port function in master.

>From gdb I get:

Starting program: /usr/cyrus/bin/master

Breakpoint 1, resolve_port (port=0x8058de0 "imap", s=0x80589d8, sin=0xbffffc2c)
    at master.c:278
278         serv = getservbyname(port, s->proto);
(gdb) print port
$5 = 0x8058de0 "imap"
(gdb) print s->proto
$6 = 0x80589b8 "tcp"
(gdb) n

Program received signal SIGSEGV, Segmentation fault.
0x08059e88 in ?? ()

I have tried copying a /etc/services from a working system with the same result 
(and even a reboot just in case the change was not picked up). I have also 
tried removing everything from services and still I get the seg fault. With 
services in place other daemons like xinetd are working (I would guess they 
would also use this function?).

Any ideas?


More information about the Info-cyrus mailing list