Replace IMAP with different version

David White dwpondscum at
Wed Aug 6 09:56:34 EDT 2003

> ??? Why downgrade?
> Also, are you sure you're not thinking of Cyrus SASL?

A previous post of mine on this mailing list follows.  The best I can figure SASL is working.  I have been following a HOWTO that
uses PHP code to graphically setup Cyrus IMAP, SASL, PAM, and MySQL for a mail server.  I have everything else working.  I simply
can not access accounts in Cyrus IMAP.  I get the same error.  I am thinking therefore it is a version conflict.  I have tried to
setup an account directly through cyradm, but I can not figure out how to setup the password.


I have configured and installed Cyrus IMAP 2.1.13 and SASL 2.1.10 and Postfix 2.0.13 on my SuSE8.1 system by following a HowTo.  I
have gotten everything to work okay, except that I can not access my IMAP accounts with a remote email client (Outlook express,
Netscape, etc).  By viewing the accounts I can see that the accounts are receiving mail and I can send mail by telnetting in to
Postfix, so I know they are working.  By viewing cyradm, I can see the accounts and the quotas are increasing.

I just wanted to make sure I am not missing something obvious, before I really have to dig deep into debug process.  I have mainly
tested with OE, because that is what most people will use to connect.  I have setup OE with the following:

Incoming / Outgoing server: (internal IP Address)
Username: (name of mailbox as shown in cyradm)
Password: (as set with cyradm)
Root Folder Path: ( / )

I can connect to my server, however, it will report the error "The server has rejected your name and password."
In my mail log, relevant information error below is displayed:

saslauthd [990]: DEBUG: auth_pam: pam_authenticate failed: User not known to the underlying authentication module
saslauthd [990]: do_auth             : auth failure: [user=hukok] [service=imap] [realm=] [mech=pam]

My users and aliases, with passwords, are stored in MySQL and retrieved by PAM with SASL.  I believe this is the an error with my
PAM or SASL, but I wanted to make sure I had configured the remote clients correctly.

David W

More information about the Info-cyrus mailing list